1. Dennis Helm
  2. Presale Questions
  3. Tuesday, 24 September 2019
  4.  Subscribe via email
Hi Folks,

i´ve made a product site, where i use EL to display within Blogviewlayout. So far so good for the first Products.
Then suddenly the linebreak / Space between two Products are gone and at the end, the Products totally felt out of the content area.

https://www.screencast.com/t/64qJqmewB0

Any Idea why? (Site URL is in the hidden credentials...)

Thanks,
Dennis
Accepted Answer
Accepted Answer Pending Moderation
Hi Dennis,
sorry for the delay. I have been strugling to find this error. Finally the problem seemed to be in the file administrator/components/com_easylayouts/output/com_content/intro_items_uikit3.php . In that line you need to look around line 68 and replace the code:


if ($view->get("columns") && (($rowcount == $view->get("columns")) or ( $counter == $introcount)))


With this one:


if ($view->get("columns")>1 && (($rowcount == $view->get("columns")) or ( $counter == $introcount)))


I have sent this fix to Geraint Edwards so hopefully it will be included in the next release ;)

Best!!
  1. more than a month ago
  2. Presale Questions
  3. # Permalink
Accepted Answer Pending Moderation
Hi Dennis,
it looks to me like the html of the layout or the article is missing a closing tag. That might be due to some of the articles not closing the tag inside the content or maybe because of the easylayouts "pre" and "post" content boxes not closing it either.
  1. more than a month ago
  2. Presale Questions
  3. # 1
Accepted Answer Pending Moderation
Hi Carlos,

thanks for getting back quickly on this.

You´re maby right, but i wonder, why the first 5 Article Items are in Order as wanted, then following two suddenly behave different and the again the following two are out of Layout.

I checked the Article Items and could not found any differences in comparison to the first 5 Items.

Also: All articles are using the same EasyLayout Template.

Any further Idea?

Thanks,
Dennis
  1. more than a month ago
  2. Presale Questions
  3. # 2
Accepted Answer Pending Moderation
Hi Carlos,

as an additional note: I´ve also checked the different Frameworks one by one, to see, if there are differences.
The Problem is on all Framework.

Dennis
  1. more than a month ago
  2. Presale Questions
  3. # 3
Accepted Answer Pending Moderation
Hi Dennis,
I'm pretty sure it's not a framework issue but a HTML issue. Debugging this is a bit tedious as you have to check which html tag is not correctly closed and therefore causing the issue. The easiest way to debug this is simplifying the layout and keep adding things till the issue shows again.

is this something youd want to do or do you rather if we do it? If you want us to take care of it, please let us know if site is already in production and be aware that while we are working on this, the layout will be changed for that specific urls (and others that use it)
  1. more than a month ago
  2. Presale Questions
  3. # 4
Accepted Answer Pending Moderation
Hi Carlos,

it would be great, if you could invest. This is not a Livesite, so no need to worry about temp. layout worries ;)
Credentials are provided and i´ll go and extend my Subscribtion righ now...

Thanks Mate,
Dnenis
  1. more than a month ago
  2. Presale Questions
  3. # 5
Accepted Answer Pending Moderation
great!! I'm on the case. I'll let you know when I find the issue.

Best!!
  1. more than a month ago
  2. Presale Questions
  3. # 6
Accepted Answer Pending Moderation
Hi Dennis,
it seems to be actually a bug in our UiKit 3 framework output for Category.blog layout (in your site it's named as Kategorie Blog) . I have reconfigured it to use Bootstrap 2 while we find a fix. You may remove my testing layouts if you wish though I would appreciate if you can keep them till we relase a fix so that we can use them if needed.

Best!!
  1. more than a month ago
  2. Presale Questions
  3. # 7
Accepted Answer Pending Moderation
Great Carlos!

Thanks for Investigating. I´ll leave your Testlayout as it is.
Dennis
  1. more than a month ago
  2. Presale Questions
  3. # 8
Accepted Answer Pending Moderation
Thank you very much!!
  1. more than a month ago
  2. Presale Questions
  3. # 9
Accepted Answer Pending Moderation
Thanks Geraint,

looking forward of the the Version.

Dennis
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!

Demo Site

You can access our demo at https://demo.easylayouts.net.

You can easily switch EasyLayouts off and on again via a special module on the demo site and can also access the backend to experiment with the layouts. The demo resets every hour so bear in mind that the demo looks a bit odd that someone else may have changed the layouts before you viewed the page.

Keep up to date

Keep up to date with news about EasyLayouts